Get in touch
Back
Resolved

Site's Domain has SSL Error

Started 12 Nov at 10:32pm EST, resolved 13 Nov at 12:26pm EST.

https://dobettercollective.com Do Better Collective Community
Resolved

Host has resolved SSL issue.

Posted 13 Nov at 12:26pm EST.
Updated

In touch with web host - they are helping to implement fix.

Posted 13 Nov at 12:40am EST.
Created

We are working to resolve this issue. Course videos will be unavailable until we fix the issue as they are only playable via our dobettercollective.com domain. We thank you for your patience while we resolve this issue.

Posted 12 Nov at 10:32pm EST.