Get in touch
Back
Downtime

Site is Down

Started 7 Jun at 05:07pm EDT, resolved 8 Jun at 08:07pm EDT.

https://collective.dobettermovement.us
Resolved

We experienced a number of website issues over the past few days. We apologize for the inconvenience this may have caused and appreciate your patience and understanding. We have stabilized the site for now, but will continue to monitor the site.

Posted 8 Jun at 08:07pm EDT.
Updated

We are working to get the site back up and running smoothly.

Posted 8 Jun at 02:01pm EDT.
Created

We are working with our host to get site back up.

Posted 7 Jun at 05:07pm EDT.