Get in touch
Back
Downtime

Site was experiencing abnormal resource load and caching issues

Started 8 Feb at 08:30am EST, resolved 8 Feb at 04:57pm EST.

https://collective.dobettermovement.us
Resolved

We are monitoring our site’s performance. We experienced a number of website issues today. We appreciate your patience and understanding. We have stabilized the site for now, but will continue to monitor the site.

Posted 8 Feb at 04:57pm EST.
Created

We are working diligently to diagnose the issue and get the site back online. Thank you for your patience.

Posted 8 Feb at 08:30am EST.